您的位置: 首页 > 编程笔记

Error: php71w-common conflicts with php-common-5.4.16-46.el7.x86_64

CentOS 阿里云 Zabbix 时间:2019-08-17  查看:21   收藏

Centos7.3 阿里云主机 安装zabbix报错

问题:

[root@lvhanzhi code]# yum install -y zabbix-web-mysql zabbix-agent mariadb-server
Error: php71w-common conflicts with php-common-5.4.16-46.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

产生的原因:

之前安装的不是php71w-common,安装zabbix需要依赖php71w-common

解决方法:

yum remove php-mysql-5.4 php php-fpm php-common   #删除之前安装的php
yum install -y zabbix-web-mysql zabbix-agent mariadb-server #重新安装zabbix

 

0% (0)
0% (0)